aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorDENG Qingfang <dengqf6@mail2.sysu.edu.cn>2020-04-06 13:17:43 +0800
committerChuanhong Guo <gch981213@gmail.com>2020-04-18 11:50:57 +0800
commit7dc82528a2751b672098faa13b58c6f214eb3b23 (patch)
tree2e98fc30a1e37dba7caffe656f07c06fdeb4a475 /target/linux
parent4745969ad7c0cb65f55c8de1f05eba786ca27f71 (diff)
downloadupstream-7dc82528a2751b672098faa13b58c6f214eb3b23.tar.gz
upstream-7dc82528a2751b672098faa13b58c6f214eb3b23.tar.bz2
upstream-7dc82528a2751b672098faa13b58c6f214eb3b23.zip
ramips: increase HiWiFi HC5962 kernel partition to 4M
Increase kernel partition because 2M is insufficient for 5.4 Because the partition changes, previous version of OpenWrt cannot upgrade to this version, and requires a new installation Recovery to stock instruction: 1. Download stock firmware at http://ur.ikcd.net/HC5962-sysupgrade-20171221-b00a04d1.bin 2. Power off the router 3. Press and hold the reset button for 4~6 sec while power it back on 4. Connect a PC to router's LAN 5. Visit http://192.168.2.1 and upload the firmware Then repeat the instruction in edae3479e64e to install OpenWrt Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/dts/mt7621_hiwifi_hc5962.dts6
-rw-r--r--target/linux/ramips/image/mt7621.mk5
2 files changed, 4 insertions, 7 deletions
diff --git a/target/linux/ramips/dts/mt7621_hiwifi_hc5962.dts b/target/linux/ramips/dts/mt7621_hiwifi_hc5962.dts
index 9d60d509ab..ec76b35840 100644
--- a/target/linux/ramips/dts/mt7621_hiwifi_hc5962.dts
+++ b/target/linux/ramips/dts/mt7621_hiwifi_hc5962.dts
@@ -74,12 +74,12 @@
partition@140000 {
label = "kernel";
- reg = <0x140000 0x200000>;
+ reg = <0x140000 0x400000>;
};
- partition@340000 {
+ partition@540000 {
label = "ubi";
- reg = <0x340000 0x1E00000>;
+ reg = <0x540000 0x1c00000>;
};
partition@2140000 {
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 6e64fb8bf1..a72f758c96 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -339,7 +339,7 @@ TARGET_DEVICES += gnubee_gb-pc2
define Device/hiwifi_hc5962
BLOCKSIZE := 128k
PAGESIZE := 2048
- KERNEL_SIZE := 2097152
+ KERNEL_SIZE := 4096k
UBINIZE_OPTS := -E 5
IMAGE_SIZE := 32768k
IMAGES += factory.bin
@@ -349,9 +349,6 @@ define Device/hiwifi_hc5962
DEVICE_VENDOR := HiWiFi
DEVICE_MODEL := HC5962
DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 wpad-basic
- SUPPORTED_DEVICES += hc5962
- # Kernel partition too small
- DEFAULT := n
endef
TARGET_DEVICES += hiwifi_hc5962