aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorMaxim Anisimov <maxim.anisimov.ua@gmail.com>2018-06-28 08:26:39 +0300
committerMathias Kresin <dev@kresin.me>2018-07-04 01:20:02 +0200
commit9e2c28472c3f3a76e16afb582fd8807d08c6dda6 (patch)
tree373507ea653a7619f844b3d0b95e74e121e2d3fe /target/linux
parentfaf64056ddd46992a75b1e277d94541c7251035c (diff)
downloadupstream-9e2c28472c3f3a76e16afb582fd8807d08c6dda6.tar.gz
upstream-9e2c28472c3f3a76e16afb582fd8807d08c6dda6.tar.bz2
upstream-9e2c28472c3f3a76e16afb582fd8807d08c6dda6.zip
ramips: move zyimage define to common Makefile
Signed-off-by: Maxim Anisimov <maxim.anisimov.ua@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/image/Makefile4
-rw-r--r--target/linux/ramips/image/mt7620.mk4
2 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index cd77ffe411..753e287d73 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -147,6 +147,10 @@ define Build/mkdlinkfw-factory
mv $@.new $@
endef
+define Build/zyimage
+ $(STAGING_DIR_HOST)/bin/zyimage $(1) $@
+endef
+
#
# The real magic happens inside these templates
#
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 325e3104a7..736741a4ba 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -16,10 +16,6 @@ define Build/elecom-header
-f $@ -C $(KDIR) v_0.0.0.bin v_0.0.0.md5
endef
-define Build/zyimage
- $(STAGING_DIR_HOST)/bin/zyimage $(1) $@
-endef
-
define Device/ai-br100
DTS := AI-BR100
IMAGE_SIZE := 7936k