aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2020-04-15 09:32:02 +0800
committerChuanhong Guo <gch981213@gmail.com>2020-04-15 10:14:19 +0800
commitad19751edc21ae713bd95df6b93be64bd1e0c612 (patch)
treecbf4a7a7e8bcd2889b58eaf89a43ed035abdab41 /target/linux
parentf814121600e5cf43fd75fe93e5b1b54f65b71bcd (diff)
downloadupstream-ad19751edc21ae713bd95df6b93be64bd1e0c612.tar.gz
upstream-ad19751edc21ae713bd95df6b93be64bd1e0c612.tar.bz2
upstream-ad19751edc21ae713bd95df6b93be64bd1e0c612.zip
ramips: mt7621: enable lzma-loader for some devices
ubnt er-x/xiaomi/netgear sercomm devices are known to have troble extracting a big kernel from flash and has support for uncompressed uimage This commit uses uncompressed uimage with lzma-loader for these devices to fix boot issue. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/image/mt7621.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 8980ff70d4..6e64fb8bf1 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -565,6 +565,7 @@ endef
TARGET_DEVICES += netgear_ex6150
define Device/netgear_sercomm_nand
+ $(Device/uimage-lzma-loader)
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL_SIZE := 4096k
@@ -658,6 +659,7 @@ endef
TARGET_DEVICES += netgear_r6850
define Device/netgear_wndr3700-v5
+ $(Device/uimage-lzma-loader)
BLOCKSIZE := 64k
IMAGE_SIZE := 15232k
SERCOMM_HWID := AYB
@@ -794,6 +796,7 @@ endef
TARGET_DEVICES += tplink_re650-v1
define Device/ubnt_edgerouter_common
+ $(Device/uimage-lzma-loader)
DEVICE_VENDOR := Ubiquiti
IMAGE_SIZE := 256768k
FILESYSTEMS := squashfs
@@ -870,6 +873,7 @@ endef
TARGET_DEVICES += wevo_w2914ns-v2
define Device/xiaomi_mir3g
+ $(Device/uimage-lzma-loader)
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL_SIZE := 4096k
@@ -889,6 +893,7 @@ endef
TARGET_DEVICES += xiaomi_mir3g
define Device/xiaomi_mir3g-v2
+ $(Device/uimage-lzma-loader)
IMAGE_SIZE := 14848k
DEVICE_VENDOR := Xiaomi
DEVICE_MODEL := Mi Router 3G
@@ -901,6 +906,7 @@ endef
TARGET_DEVICES += xiaomi_mir3g-v2
define Device/xiaomi_mir3p
+ $(Device/uimage-lzma-loader)
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL_SIZE:= 4096k