aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorChristoph Krapp <achterin@googlemail.com>2020-07-06 23:05:25 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-07 00:40:04 +0200
commitba0f4f0cfddc6f1152273565ec35f2a0bda1e95d (patch)
tree4070713b946d4ae29597b251f9b7c6910641ee18 /target
parent982468de35d499f85470b7b547d2b27cea53bae0 (diff)
downloadupstream-ba0f4f0cfddc6f1152273565ec35f2a0bda1e95d.tar.gz
upstream-ba0f4f0cfddc6f1152273565ec35f2a0bda1e95d.tar.bz2
upstream-ba0f4f0cfddc6f1152273565ec35f2a0bda1e95d.zip
ramips: add support for TP-Link RE500 v1
This device uses the same hardware as RE650 v1 which got supported in 8c51dde. Hardware specification: - SoC 880 MHz - MediaTek MT7621AT - 128 MB of DDR3 RAM - 16 MB - Winbond 25Q128FVSG - 4T4R 2.4 GHz - MediaTek MT7615E - 4T4R 5 GHz - MediaTek MT7615E - 1x 1 Gbps Ethernet - MT7621AT integrated - 7x LEDs (Power, 2G, 5G, WPS(x2), Lan(x2)) - 4x buttons (Reset, Power, WPS, LED) - UART header (J1) - 2:GND, 3:RX, 4:TX Serial console @ 57600,8n1 Flash instructions: Upload openwrt-ramips-mt7621-tplink_re500-v1-squashfs-factory.bin from the RE500 web interface. TFTP recovery to stock firmware: Unfortunately, I can't find an easy way to recover the RE without opening the device and using modified binaries. The TFTP upload will only work if selected from u-boot, which means you have to open the device and attach to the serial console. The TFTP update procedure does *not* accept the published vendor firmware binaries. However, it allows to flash kernel + rootfs binaries, and this works if you have a backup of the original contents of the flash. It's probably possible to create special image out of the vendor binaries and use that as recovery image. Signed-off-by: Christoph Krapp <achterin@googlemail.com> [remove dts-v1 in DTSI, do not touch WiFi LEDs for RE650, keep state_default in DTS files, fix label-mac-device, use lower case for WiFi LEDs] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/mt7621_tplink_re500-v1.dts64
-rw-r--r--target/linux/ramips/dts/mt7621_tplink_re650-v1.dts126
-rw-r--r--target/linux/ramips/dts/mt7621_tplink_rexx0-v1.dtsi131
-rw-r--r--target/linux/ramips/image/mt7621.mk10
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/etc/board.d/01_leds4
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/etc/board.d/02_network1
6 files changed, 211 insertions, 125 deletions
diff --git a/target/linux/ramips/dts/mt7621_tplink_re500-v1.dts b/target/linux/ramips/dts/mt7621_tplink_re500-v1.dts
new file mode 100644
index 0000000000..600342a822
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_tplink_re500-v1.dts
@@ -0,0 +1,64 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7621_tplink_rexx0-v1.dtsi"
+
+/ {
+ compatible = "tplink,re500-v1", "mediatek,mt7621-soc";
+ model = "TP-Link RE500 v1";
+
+ aliases {
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power: power {
+ label = "re500-v1:blue:power";
+ gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
+ };
+
+ wifi2g {
+ label = "re500-v1:blue:wifi2g";
+ gpios = <&gpio 23 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ wifi5g {
+ label = "re500-v1:blue:wifi5g";
+ gpios = <&gpio 24 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+
+ wps_red {
+ label = "re500-v1:red:wps";
+ gpios = <&gpio 26 GPIO_ACTIVE_HIGH>;
+ };
+
+ wps_blue {
+ label = "re500-v1:blue:wps";
+ gpios = <&gpio 27 GPIO_ACTIVE_HIGH>;
+ };
+
+ eth_act {
+ label = "re500-v1:green:eth_act";
+ gpios = <&gpio 28 GPIO_ACTIVE_LOW>;
+ };
+
+ eth_link {
+ label = "re500-v1:green:eth_link";
+ gpios = <&gpio 29 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&state_default {
+ gpio {
+ groups = "rgmii2", "wdt";
+ function = "gpio";
+ };
+};
diff --git a/target/linux/ramips/dts/mt7621_tplink_re650-v1.dts b/target/linux/ramips/dts/mt7621_tplink_re650-v1.dts
index d5ae954189..ab8805f163 100644
--- a/target/linux/ramips/dts/mt7621_tplink_re650-v1.dts
+++ b/target/linux/ramips/dts/mt7621_tplink_re650-v1.dts
@@ -1,10 +1,7 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
/dts-v1/;
-#include "mt7621.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
+#include "mt7621_tplink_rexx0-v1.dtsi"
/ {
compatible = "tplink,re650-v1", "mediatek,mt7621-soc";
@@ -15,11 +12,6 @@
led-failsafe = &led_power;
led-running = &led_power;
led-upgrade = &led_power;
- label-mac-device = &gmac0;
- };
-
- chosen {
- bootargs = "console=ttyS0,57600";
};
leds {
@@ -60,124 +52,8 @@
gpios = <&gpio 29 GPIO_ACTIVE_LOW>;
};
};
-
- keys {
- compatible = "gpio-keys";
-
- wps {
- label = "wps";
- gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- linux,code = <KEY_WPS_BUTTON>;
- };
-
- power {
- label = "power";
- gpios = <&gpio 25 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- linux,code = <KEY_POWER>;
- };
-
- led {
- label = "led";
- gpios = <&gpio 30 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- linux,code = <KEY_LIGHTS_TOGGLE>;
- };
-
- reset {
- label = "reset";
- gpios = <&gpio 31 GPIO_ACTIVE_LOW>;
- debounce-interval = <60>;
- linux,code = <KEY_RESTART>;
- };
- };
};
-&spi0 {
- status = "okay";
-
- flash@0 {
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <40000000>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "u-boot";
- reg = <0x0 0x20000>;
- read-only;
- };
-
- partition@20000 {
- compatible = "tplink,firmware";
- label = "firmware";
- reg = <0x20000 0xde0000>;
- };
-
- config: partition@e00000 {
- label = "config";
- reg = <0xe00000 0x50000>;
- read-only;
- };
-
- /* range 0xe50000 to 0xff0000 is empty in vendor
- * firmware, so we do not use it either
- */
-
- radio: partition@ff0000 {
- label = "radio";
- reg = <0xff0000 0x10000>;
- read-only;
- };
- };
- };
-};
-
-&pcie {
- status = "okay";
-};
-
-&pcie0 {
- wifi@0,0 {
- compatible = "mediatek,mt76";
- reg = <0x0000 0 0 0 0>;
- mediatek,mtd-eeprom = <&radio 0x0>;
- mtd-mac-address = <&config 0x10008>;
- mtd-mac-address-increment = <1>;
- ieee80211-freq-limit = <2400000 2500000>;
- };
-};
-
-&pcie1 {
- wifi@0,0 {
- compatible = "mediatek,mt76";
- reg = <0x0000 0 0 0 0>;
- mediatek,mtd-eeprom = <&radio 0x8000>;
- mtd-mac-address = <&config 0x10008>;
- mtd-mac-address-increment = <2>;
- ieee80211-freq-limit = <5000000 6000000>;
- };
-};
-
-&gmac0 {
- mtd-mac-address = <&config 0x10008>;
-};
-
-&switch0 {
- ports {
- port@0 {
- status = "okay";
- label = "lan";
- };
- };
-};
-
-
&state_default {
gpio {
groups = "rgmii2", "wdt";
diff --git a/target/linux/ramips/dts/mt7621_tplink_rexx0-v1.dtsi b/target/linux/ramips/dts/mt7621_tplink_rexx0-v1.dtsi
new file mode 100644
index 0000000000..fa9d16a55a
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_tplink_rexx0-v1.dtsi
@@ -0,0 +1,131 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ aliases {
+ label-mac-device = &gmac0;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,57600";
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ wps {
+ label = "wps";
+ gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+
+ power {
+ label = "power";
+ gpios = <&gpio 25 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ linux,code = <KEY_POWER>;
+ };
+
+ led {
+ label = "led";
+ gpios = <&gpio 30 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ linux,code = <KEY_LIGHTS_TOGGLE>;
+ };
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 31 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x20000>;
+ read-only;
+ };
+
+ partition@20000 {
+ compatible = "tplink,firmware";
+ label = "firmware";
+ reg = <0x20000 0xde0000>;
+ };
+
+ config: partition@e00000 {
+ label = "config";
+ reg = <0xe00000 0x50000>;
+ read-only;
+ };
+
+ /* range 0xe50000 to 0xff0000 is empty in vendor
+ * firmware, so we do not use it either
+ */
+
+ radio: partition@ff0000 {
+ label = "radio";
+ reg = <0xff0000 0x10000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&radio 0x0>;
+ mtd-mac-address = <&config 0x10008>;
+ mtd-mac-address-increment = <1>;
+ ieee80211-freq-limit = <2400000 2500000>;
+ };
+};
+
+&pcie1 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&radio 0x8000>;
+ mtd-mac-address = <&config 0x10008>;
+ mtd-mac-address-increment = <2>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+};
+
+&gmac0 {
+ mtd-mac-address = <&config 0x10008>;
+};
+
+&switch0 {
+ ports {
+ port@0 {
+ status = "okay";
+ label = "lan";
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index de20934598..d7a4b9fa7c 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -842,6 +842,16 @@ define Device/tplink_re350-v1
endef
TARGET_DEVICES += tplink_re350-v1
+define Device/tplink_re500-v1
+ $(Device/tplink-safeloader)
+ DEVICE_MODEL := RE500
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-mt7615e wpad-basic
+ TPLINK_BOARD_ID := RE500-V1
+ IMAGE_SIZE := 14208k
+endef
+TARGET_DEVICES += tplink_re500-v1
+
define Device/tplink_re650-v1
$(Device/tplink-safeloader)
DEVICE_MODEL := RE650
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds b/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
index 716bc6e462..2e3dca7901 100755
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
@@ -75,6 +75,10 @@ tplink,re650-v1)
ucidef_set_led_netdev "eth_act" "LAN act" "$boardname:green:eth_act" "lan" "tx rx"
ucidef_set_led_netdev "eth_link" "LAN link" "$boardname:green:eth_link" "lan" "link"
;;
+tplink,re500-v1)
+ ucidef_set_led_netdev "eth_act" "LAN act" "$boardname:green:eth_act" "lan" "tx rx"
+ ucidef_set_led_netdev "eth_link" "LAN link" "$boardname:green:eth_link" "lan" "link"
+ ;;
xzwifi,creativebox-v1)
ucidef_set_led_netdev "internet" "internet" "$boardname:blue:internet" "wan"
;;
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index 03cc921be3..a276d082e9 100755
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -37,6 +37,7 @@ ramips_setup_interfaces()
netgear,ex6150|\
thunder,timecloud|\
tplink,re350-v1|\
+ tplink,re500-v1|\
tplink,re650-v1|\
ubnt,unifi-nanohd)
ucidef_set_interface_lan "lan"