aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/other.mk16
-rw-r--r--target/linux/imx6/config-4.43
2 files changed, 2 insertions, 17 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index a4f22e406c..30d145d7f2 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -618,22 +618,6 @@ endef
$(eval $(call KernelPackage,rtc-pt7c4338))
-define KernelPackage/rtc-snvs
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Freescale SNVS RTC support
- DEPENDS:=@TARGET_imx6 @RTC_SUPPORT
- KCONFIG:=CONFIG_RTC_DRV_SNVS \
- CONFIG_RTC_CLASS=y
- FILES:=$(LINUX_DIR)/drivers/rtc/rtc-snvs.ko
- AUTOLOAD:=$(call AutoLoad,50,rtc-snvs,1)
-endef
-
-define KernelPackage/rtc-snvs/description
- Kernel module for Freescale SNVS RTC on chip module
-endef
-
-$(eval $(call KernelPackage,rtc-snvs))
-
define KernelPackage/rtc-rs5c372a
SUBMENU:=$(OTHER_MENU)
TITLE:=Ricoh R2025S/D, RS5C372A/B, RV5C386, RV5C387A
diff --git a/target/linux/imx6/config-4.4 b/target/linux/imx6/config-4.4
index ac8987a82b..44c0e99f3a 100644
--- a/target/linux/imx6/config-4.4
+++ b/target/linux/imx6/config-4.4
@@ -123,7 +123,6 @@ CONFIG_DMADEVICES=y
CONFIG_DMA_ENGINE=y
CONFIG_DMA_OF=y
CONFIG_DTC=y
-# CONFIG_DW_DMAC_PCI is not set
CONFIG_EDAC_ATOMIC_SCRUB=y
CONFIG_EDAC_SUPPORT=y
# CONFIG_ENABLE_DEFAULT_TRACERS is not set
@@ -301,6 +300,7 @@ CONFIG_OLD_SIGACTION=y
CONFIG_OLD_SIGSUSPEND3=y
CONFIG_OUTER_CACHE=y
CONFIG_OUTER_CACHE_SYNC=y
+CONFIG_PADATA=y
CONFIG_PAGE_OFFSET=0x80000000
CONFIG_PCI=y
CONFIG_PCIEAER=y
@@ -353,6 +353,7 @@ CONFIG_RTC_DRV_DS1307=y
CONFIG_RTC_DRV_DS1672=y
# CONFIG_RTC_DRV_IMXDI is not set
# CONFIG_RTC_DRV_MXC is not set
+CONFIG_RTC_DRV_SNVS=y
CONFIG_RWSEM_SPIN_ON_OWNER=y
CONFIG_RWSEM_XCHGADD_ALGORITHM=y
CONFIG_SATA_AHCI_PLATFORM=y