summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name <you@example.com>2023-01-28 11:04:26 +0000
committerYour Name <you@example.com>2023-01-28 11:04:26 +0000
commitb0f53621f469b655666d9405bd9bbce710821a46 (patch)
tree0138992933b011dea1fde55d3073e0855334b5e6
parent3f091bd5ad4e8bb26bc74639425a6eb9186be231 (diff)
downloadindi_mount_driver-b0f53621f469b655666d9405bd9bbce710821a46.tar.gz
indi_mount_driver-b0f53621f469b655666d9405bd9bbce710821a46.tar.bz2
indi_mount_driver-b0f53621f469b655666d9405bd9bbce710821a46.zip
tidy up build
-rw-r--r--.gitignore17
-rw-r--r--Makefile24
-rw-r--r--indi-lxd650/Makefile277
3 files changed, 16 insertions, 302 deletions
diff --git a/.gitignore b/.gitignore
index 722d4be..5c7bba5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,18 +1,5 @@
-indi-celestronaux/CMakeCache.txt
-indi-celestronaux/CMakeFiles/
-indi-celestronaux/Makefile
-indi-celestronaux/cmake_install.cmake
-indi-celestronaux/config.h
-indi-celestronaux/indi_celestronaux.xml
-indi-celestronaux/indi_celestron_aux
-indi-celestronaux/install_manifest.txt
-indi-lxd650/CMakeCache.txt
-indi-lxd650/CMakeFiles/
-indi-lxd650/Makefile
-indi-lxd650/cmake_install.cmake
-indi-lxd650/config.h
-indi-lxd650/indi_lxd650
-indi-lxd650/indi_lxd650.xml
+indi-celestronaux/build
+indi-lxd650/build
*.orig
*.swp
diff --git a/Makefile b/Makefile
index ac9f08d..6451b49 100644
--- a/Makefile
+++ b/Makefile
@@ -1,16 +1,20 @@
-D=indi-celestronaux
+D=indi-celestronaux indi-lxd650
-default: indi-celestronaux/make indi-lxd650/make
+default: ${D:%=%/default}
+clean: ${D:%=%/clean}
+install: ${D:%=%/install}
-install: indi-celestronaux/install indi-lxd650/install
+%/install:%/default
+ (cd ${@:%/install=%/build} && make install)
-%/install:%/make
- (cd ${@:%/install=%} && make install)
+%/default:%/build/Makefile
+ (cd ${@:%/default=%/build} && make)
-%/make:%/Makefile
- (cd ${@:%/make=%} && make)
+%/build/Makefile:
+ mkdir -p ${@:%/Makefile=%}
+ (cd ${@:%/Makefile=%} && cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr ..)
-
-%/Makefile:
- (cd ${@:%/Makefile=%} && cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr)
+%/clean:
+ /bin/rm -rf ${@:%/clean=%/build}
+
diff --git a/indi-lxd650/Makefile b/indi-lxd650/Makefile
deleted file mode 100644
index 01ba528..0000000
--- a/indi-lxd650/Makefile
+++ /dev/null
@@ -1,277 +0,0 @@
-# CMAKE generated file: DO NOT EDIT!
-# Generated by "Unix Makefiles" Generator, CMake Version 3.18
-
-# Default target executed when no arguments are given to make.
-default_target: all
-
-.PHONY : default_target
-
-# Allow only one "make -f Makefile2" at a time, but pass parallelism.
-.NOTPARALLEL:
-
-
-#=============================================================================
-# Special targets provided by cmake.
-
-# Disable implicit rules so canonical targets will work.
-.SUFFIXES:
-
-
-# Disable VCS-based implicit rules.
-% : %,v
-
-
-# Disable VCS-based implicit rules.
-% : RCS/%
-
-
-# Disable VCS-based implicit rules.
-% : RCS/%,v
-
-
-# Disable VCS-based implicit rules.
-% : SCCS/s.%
-
-
-# Disable VCS-based implicit rules.
-% : s.%
-
-
-.SUFFIXES: .hpux_make_needs_suffix_list
-
-
-# Command-line flag to silence nested $(MAKE).
-$(VERBOSE)MAKESILENT = -s
-
-#Suppress display of executed commands.
-$(VERBOSE).SILENT:
-
-# A target that is always out of date.
-cmake_force:
-
-.PHONY : cmake_force
-
-#=============================================================================
-# Set environment variables for the build.
-
-# The shell in which to execute make rules.
-SHELL = /bin/sh
-
-# The CMake executable.
-CMAKE_COMMAND = /usr/bin/cmake
-
-# The command to remove a file.
-RM = /usr/bin/cmake -E rm -f
-
-# Escaping for special characters.
-EQUALS = =
-
-# The top-level source directory on which CMake was run.
-CMAKE_SOURCE_DIR = /root/projects/indi/indi_mount_driver/indi-lxd650
-
-# The top-level build directory on which CMake was run.
-CMAKE_BINARY_DIR = /root/projects/indi/indi_mount_driver/indi-lxd650
-
-#=============================================================================
-# Targets provided globally by CMake.
-
-# Special rule for the target install/strip
-install/strip: preinstall
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Installing the project stripped..."
- /usr/bin/cmake -DCMAKE_INSTALL_DO_STRIP=1 -P cmake_install.cmake
-.PHONY : install/strip
-
-# Special rule for the target install/strip
-install/strip/fast: preinstall/fast
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Installing the project stripped..."
- /usr/bin/cmake -DCMAKE_INSTALL_DO_STRIP=1 -P cmake_install.cmake
-.PHONY : install/strip/fast
-
-# Special rule for the target install/local
-install/local: preinstall
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Installing only the local directory..."
- /usr/bin/cmake -DCMAKE_INSTALL_LOCAL_ONLY=1 -P cmake_install.cmake
-.PHONY : install/local
-
-# Special rule for the target install/local
-install/local/fast: preinstall/fast
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Installing only the local directory..."
- /usr/bin/cmake -DCMAKE_INSTALL_LOCAL_ONLY=1 -P cmake_install.cmake
-.PHONY : install/local/fast
-
-# Special rule for the target install
-install: preinstall
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Install the project..."
- /usr/bin/cmake -P cmake_install.cmake
-.PHONY : install
-
-# Special rule for the target install
-install/fast: preinstall/fast
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Install the project..."
- /usr/bin/cmake -P cmake_install.cmake
-.PHONY : install/fast
-
-# Special rule for the target list_install_components
-list_install_components:
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Available install components are: \"Unspecified\""
-.PHONY : list_install_components
-
-# Special rule for the target list_install_components
-list_install_components/fast: list_install_components
-
-.PHONY : list_install_components/fast
-
-# Special rule for the target rebuild_cache
-rebuild_cache:
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Running CMake to regenerate build system..."
- /usr/bin/cmake --regenerate-during-build -S$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR)
-.PHONY : rebuild_cache
-
-# Special rule for the target rebuild_cache
-rebuild_cache/fast: rebuild_cache
-
-.PHONY : rebuild_cache/fast
-
-# Special rule for the target edit_cache
-edit_cache:
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "No interactive CMake dialog available..."
- /usr/bin/cmake -E echo No\ interactive\ CMake\ dialog\ available.
-.PHONY : edit_cache
-
-# Special rule for the target edit_cache
-edit_cache/fast: edit_cache
-
-.PHONY : edit_cache/fast
-
-# The main all target
-all: cmake_check_build_system
- $(CMAKE_COMMAND) -E cmake_progress_start /root/projects/indi/indi_mount_driver/indi-lxd650/CMakeFiles /root/projects/indi/indi_mount_driver/indi-lxd650//CMakeFiles/progress.marks
- $(MAKE) $(MAKESILENT) -f CMakeFiles/Makefile2 all
- $(CMAKE_COMMAND) -E cmake_progress_start /root/projects/indi/indi_mount_driver/indi-lxd650/CMakeFiles 0
-.PHONY : all
-
-# The main clean target
-clean:
- $(MAKE) $(MAKESILENT) -f CMakeFiles/Makefile2 clean
-.PHONY : clean
-
-# The main clean target
-clean/fast: clean
-
-.PHONY : clean/fast
-
-# Prepare targets for installation.
-preinstall: all
- $(MAKE) $(MAKESILENT) -f CMakeFiles/Makefile2 preinstall
-.PHONY : preinstall
-
-# Prepare targets for installation.
-preinstall/fast:
- $(MAKE) $(MAKESILENT) -f CMakeFiles/Makefile2 preinstall
-.PHONY : preinstall/fast
-
-# clear depends
-depend:
- $(CMAKE_COMMAND) -S$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR) --check-build-system CMakeFiles/Makefile.cmake 1
-.PHONY : depend
-
-#=============================================================================
-# Target rules for targets named indi_lxd650
-
-# Build rule for target.
-indi_lxd650: cmake_check_build_system
- $(MAKE) $(MAKESILENT) -f CMakeFiles/Makefile2 indi_lxd650
-.PHONY : indi_lxd650
-
-# fast build rule for target.
-indi_lxd650/fast:
- $(MAKE) $(MAKESILENT) -f CMakeFiles/indi_lxd650.dir/build.make CMakeFiles/indi_lxd650.dir/build
-.PHONY : indi_lxd650/fast
-
-lx200driver.o: lx200driver.cpp.o
-
-.PHONY : lx200driver.o
-
-# target to build an object file
-lx200driver.cpp.o:
- $(MAKE) $(MAKESILENT) -f CMakeFiles/indi_lxd650.dir/build.make CMakeFiles/indi_lxd650.dir/lx200driver.cpp.o
-.PHONY : lx200driver.cpp.o
-
-lx200driver.i: lx200driver.cpp.i
-
-.PHONY : lx200driver.i
-
-# target to preprocess a source file
-lx200driver.cpp.i:
- $(MAKE) $(MAKESILENT) -f CMakeFiles/indi_lxd650.dir/build.make CMakeFiles/indi_lxd650.dir/lx200driver.cpp.i
-.PHONY : lx200driver.cpp.i
-
-lx200driver.s: lx200driver.cpp.s
-
-.PHONY : lx200driver.s
-
-# target to generate assembly for a file
-lx200driver.cpp.s:
- $(MAKE) $(MAKESILENT) -f CMakeFiles/indi_lxd650.dir/build.make CMakeFiles/indi_lxd650.dir/lx200driver.cpp.s
-.PHONY : lx200driver.cpp.s
-
-lxd650.o: lxd650.cpp.o
-
-.PHONY : lxd650.o
-
-# target to build an object file
-lxd650.cpp.o:
- $(MAKE) $(MAKESILENT) -f CMakeFiles/indi_lxd650.dir/build.make CMakeFiles/indi_lxd650.dir/lxd650.cpp.o
-.PHONY : lxd650.cpp.o
-
-lxd650.i: lxd650.cpp.i
-
-.PHONY : lxd650.i
-
-# target to preprocess a source file
-lxd650.cpp.i:
- $(MAKE) $(MAKESILENT) -f CMakeFiles/indi_lxd650.dir/build.make CMakeFiles/indi_lxd650.dir/lxd650.cpp.i
-.PHONY : lxd650.cpp.i
-
-lxd650.s: lxd650.cpp.s
-
-.PHONY : lxd650.s
-
-# target to generate assembly for a file
-lxd650.cpp.s:
- $(MAKE) $(MAKESILENT) -f CMakeFiles/indi_lxd650.dir/build.make CMakeFiles/indi_lxd650.dir/lxd650.cpp.s
-.PHONY : lxd650.cpp.s
-
-# Help Target
-help:
- @echo "The following are some of the valid targets for this Makefile:"
- @echo "... all (the default if no target is provided)"
- @echo "... clean"
- @echo "... depend"
- @echo "... edit_cache"
- @echo "... install"
- @echo "... install/local"
- @echo "... install/strip"
- @echo "... list_install_components"
- @echo "... rebuild_cache"
- @echo "... indi_lxd650"
- @echo "... lx200driver.o"
- @echo "... lx200driver.i"
- @echo "... lx200driver.s"
- @echo "... lxd650.o"
- @echo "... lxd650.i"
- @echo "... lxd650.s"
-.PHONY : help
-
-
-
-#=============================================================================
-# Special targets to cleanup operation of make.
-
-# Special rule to run CMake to check the build system integrity.
-# No rule that depends on this can have commands that come from listfiles
-# because they might be regenerated.
-cmake_check_build_system:
- $(CMAKE_COMMAND) -S$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR) --check-build-system CMakeFiles/Makefile.cmake 0
-.PHONY : cmake_check_build_system
-