aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/TIVA/TM4C123x/hal_lld.c
diff options
context:
space:
mode:
authormarcoveeneman <marco-veeneman@hotmail.com>2015-03-17 21:49:01 +0100
committermarcoveeneman <marco-veeneman@hotmail.com>2015-03-17 21:49:01 +0100
commit7a68c44dd0c92c551604ad54619abafcc2477afa (patch)
treee4176856fb50ca9febeb5379b43ea0a169374bc8 /os/hal/ports/TIVA/TM4C123x/hal_lld.c
parentc38910ced9a3dd587ec0d1685e298d66770a8311 (diff)
downloadChibiOS-Contrib-7a68c44dd0c92c551604ad54619abafcc2477afa.tar.gz
ChibiOS-Contrib-7a68c44dd0c92c551604ad54619abafcc2477afa.tar.bz2
ChibiOS-Contrib-7a68c44dd0c92c551604ad54619abafcc2477afa.zip
Added Tiva UDMA initialization in hal_lld of TM4C123x devices.
Added UDMA and SPI driver to platform.mk of TM4C123x devices.
Diffstat (limited to 'os/hal/ports/TIVA/TM4C123x/hal_lld.c')
-rw-r--r--os/hal/ports/TIVA/TM4C123x/hal_lld.c4
1 files changed, 4 insertions, 0 deletions
diff --git a/os/hal/ports/TIVA/TM4C123x/hal_lld.c b/os/hal/ports/TIVA/TM4C123x/hal_lld.c
index 7a6046d..f259151 100644
--- a/os/hal/ports/TIVA/TM4C123x/hal_lld.c
+++ b/os/hal/ports/TIVA/TM4C123x/hal_lld.c
@@ -131,6 +131,10 @@ void tiva_clock_init(void)
#if HAL_USE_PWM
SYSCTL->RCC |= TIVA_PWM_FIELDS;
#endif
+
+#if defined(TIVA_UDMA_REQUIRED)
+ udmaInit();
+#endif
}
/**