aboutsummaryrefslogtreecommitdiffstats
path: root/icezum/blink/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'icezum/blink/Makefile')
-rw-r--r--icezum/blink/Makefile32
1 files changed, 0 insertions, 32 deletions
diff --git a/icezum/blink/Makefile b/icezum/blink/Makefile
deleted file mode 100644
index e7c2964..0000000
--- a/icezum/blink/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-PROJ = blink
-PIN_DEF = blink.pcf
-DEVICE = hx1k
-
-all: $(PROJ).rpt $(PROJ).bin
-
-%.blif: %.vhdl
- ghdl -a $(PROJ).vhdl
- yosys -m ../../ghdl.so -p 'ghdl $(PROJ); synth_ice40 -blif $@'
-
-
-%.asc: $(PIN_DEF) %.blif
- arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^
-
-%.bin: %.asc
- icepack $< $@
-
-%.rpt: %.asc
- icetime -d $(DEVICE) -mtr $@ $<
-
-prog: $(PROJ).bin
- iceprog $<
-
-sudo-prog: $(PROJ).bin
- @echo 'Executing prog as root!!!'
- sudo iceprog $<
-
-clean:
- rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin work-obj93.cf
-
-.SECONDARY:
-.PHONY: all prog clean