aboutsummaryrefslogtreecommitdiffstats
path: root/icezum/blink
diff options
context:
space:
mode:
Diffstat (limited to 'icezum/blink')
-rw-r--r--icezum/blink/Makefile32
-rw-r--r--icezum/blink/README.md16
-rw-r--r--icezum/blink/blink.pcf11
-rw-r--r--icezum/blink/blink.vhdl35
4 files changed, 0 insertions, 94 deletions
diff --git a/icezum/blink/Makefile b/icezum/blink/Makefile
deleted file mode 100644
index e7c2964..0000000
--- a/icezum/blink/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-PROJ = blink
-PIN_DEF = blink.pcf
-DEVICE = hx1k
-
-all: $(PROJ).rpt $(PROJ).bin
-
-%.blif: %.vhdl
- ghdl -a $(PROJ).vhdl
- yosys -m ../../ghdl.so -p 'ghdl $(PROJ); synth_ice40 -blif $@'
-
-
-%.asc: $(PIN_DEF) %.blif
- arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^
-
-%.bin: %.asc
- icepack $< $@
-
-%.rpt: %.asc
- icetime -d $(DEVICE) -mtr $@ $<
-
-prog: $(PROJ).bin
- iceprog $<
-
-sudo-prog: $(PROJ).bin
- @echo 'Executing prog as root!!!'
- sudo iceprog $<
-
-clean:
- rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin work-obj93.cf
-
-.SECONDARY:
-.PHONY: all prog clean
diff --git a/icezum/blink/README.md b/icezum/blink/README.md
deleted file mode 100644
index e61330b..0000000
--- a/icezum/blink/README.md
+++ /dev/null
@@ -1,16 +0,0 @@
-A hello world example for the **Icezum Alhambra board**
-It just blinks all the leds
-
-Execute
-
-```sh
-$ make
-```
-
-for synthesizing the example and
-
-```sh
-$ make prog
-```
-
-for programing the board
diff --git a/icezum/blink/blink.pcf b/icezum/blink/blink.pcf
deleted file mode 100644
index 2f686f6..0000000
--- a/icezum/blink/blink.pcf
+++ /dev/null
@@ -1,11 +0,0 @@
-set_io led0 95
-set_io led1 96
-set_io led2 97
-set_io led3 98
-set_io led4 99
-set_io led5 101
-set_io led6 102
-set_io led7 104
-set_io clk 21
-
-
diff --git a/icezum/blink/blink.vhdl b/icezum/blink/blink.vhdl
deleted file mode 100644
index 9279622..0000000
--- a/icezum/blink/blink.vhdl
+++ /dev/null
@@ -1,35 +0,0 @@
-library ieee;
-use ieee.std_logic_1164.all;
-use ieee.numeric_std.all;
-
-entity blink is
- port (clk : in std_logic;
- led0, led1, led2, led3, led4, led5, led6, led7 : out std_logic);
-end blink;
-
-architecture synth of blink is
- signal clk_4hz: std_logic;
-begin
- process (clk)
- -- 3_000_000 is 0x2dc6c0
- variable counter : unsigned (23 downto 0);
- begin
- if rising_edge(clk) then
- if counter = 2_999_999 then
- counter := x"000000";
- clk_4hz <= not clk_4hz;
- else
- counter := counter + 1;
- end if;
- end if;
- end process;
-
- led0 <= clk_4hz;
- led1 <= clk_4hz;
- led2 <= clk_4hz;
- led3 <= clk_4hz;
- led4 <= clk_4hz;
- led5 <= clk_4hz;
- led6 <= clk_4hz;
- led7 <= clk_4hz;
-end synth;