aboutsummaryrefslogtreecommitdiffstats
path: root/icezum
diff options
context:
space:
mode:
Diffstat (limited to 'icezum')
-rw-r--r--icezum/blink/Makefile32
-rw-r--r--icezum/blink/README.md16
-rw-r--r--icezum/blink/blink.pcf11
-rw-r--r--icezum/blink/blink.vhdl35
-rw-r--r--icezum/counter-8bits/Makefile32
-rw-r--r--icezum/counter-8bits/README.md16
-rw-r--r--icezum/counter-8bits/counter8.pcf9
-rw-r--r--icezum/counter-8bits/counter8.vhdl38
-rw-r--r--icezum/led_on/Makefile31
-rw-r--r--icezum/led_on/README.md16
-rw-r--r--icezum/led_on/led_on.pcf9
-rw-r--r--icezum/led_on/led_on.vhdl20
-rw-r--r--icezum/pushbutton/Makefile32
-rw-r--r--icezum/pushbutton/README.md17
-rw-r--r--icezum/pushbutton/pushbutton.pcf7
-rw-r--r--icezum/pushbutton/pushbutton.vhdl14
-rw-r--r--icezum/pushbutton_and/Makefile32
-rw-r--r--icezum/pushbutton_and/README.md17
-rw-r--r--icezum/pushbutton_and/pushbutton_and.pcf4
-rw-r--r--icezum/pushbutton_and/pushbutton_and.vhdl18
20 files changed, 0 insertions, 406 deletions
diff --git a/icezum/blink/Makefile b/icezum/blink/Makefile
deleted file mode 100644
index e7c2964..0000000
--- a/icezum/blink/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-PROJ = blink
-PIN_DEF = blink.pcf
-DEVICE = hx1k
-
-all: $(PROJ).rpt $(PROJ).bin
-
-%.blif: %.vhdl
- ghdl -a $(PROJ).vhdl
- yosys -m ../../ghdl.so -p 'ghdl $(PROJ); synth_ice40 -blif $@'
-
-
-%.asc: $(PIN_DEF) %.blif
- arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^
-
-%.bin: %.asc
- icepack $< $@
-
-%.rpt: %.asc
- icetime -d $(DEVICE) -mtr $@ $<
-
-prog: $(PROJ).bin
- iceprog $<
-
-sudo-prog: $(PROJ).bin
- @echo 'Executing prog as root!!!'
- sudo iceprog $<
-
-clean:
- rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin work-obj93.cf
-
-.SECONDARY:
-.PHONY: all prog clean
diff --git a/icezum/blink/README.md b/icezum/blink/README.md
deleted file mode 100644
index e61330b..0000000
--- a/icezum/blink/README.md
+++ /dev/null
@@ -1,16 +0,0 @@
-A hello world example for the **Icezum Alhambra board**
-It just blinks all the leds
-
-Execute
-
-```sh
-$ make
-```
-
-for synthesizing the example and
-
-```sh
-$ make prog
-```
-
-for programing the board
diff --git a/icezum/blink/blink.pcf b/icezum/blink/blink.pcf
deleted file mode 100644
index 2f686f6..0000000
--- a/icezum/blink/blink.pcf
+++ /dev/null
@@ -1,11 +0,0 @@
-set_io led0 95
-set_io led1 96
-set_io led2 97
-set_io led3 98
-set_io led4 99
-set_io led5 101
-set_io led6 102
-set_io led7 104
-set_io clk 21
-
-
diff --git a/icezum/blink/blink.vhdl b/icezum/blink/blink.vhdl
deleted file mode 100644
index 9279622..0000000
--- a/icezum/blink/blink.vhdl
+++ /dev/null
@@ -1,35 +0,0 @@
-library ieee;
-use ieee.std_logic_1164.all;
-use ieee.numeric_std.all;
-
-entity blink is
- port (clk : in std_logic;
- led0, led1, led2, led3, led4, led5, led6, led7 : out std_logic);
-end blink;
-
-architecture synth of blink is
- signal clk_4hz: std_logic;
-begin
- process (clk)
- -- 3_000_000 is 0x2dc6c0
- variable counter : unsigned (23 downto 0);
- begin
- if rising_edge(clk) then
- if counter = 2_999_999 then
- counter := x"000000";
- clk_4hz <= not clk_4hz;
- else
- counter := counter + 1;
- end if;
- end if;
- end process;
-
- led0 <= clk_4hz;
- led1 <= clk_4hz;
- led2 <= clk_4hz;
- led3 <= clk_4hz;
- led4 <= clk_4hz;
- led5 <= clk_4hz;
- led6 <= clk_4hz;
- led7 <= clk_4hz;
-end synth;
diff --git a/icezum/counter-8bits/Makefile b/icezum/counter-8bits/Makefile
deleted file mode 100644
index c618b42..0000000
--- a/icezum/counter-8bits/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-PROJ = counter8
-PIN_DEF = counter8.pcf
-DEVICE = hx1k
-
-all: $(PROJ).rpt $(PROJ).bin
-
-%.blif: %.vhdl
- ghdl -a $(PROJ).vhdl
- yosys -m ../../ghdl.so -p 'ghdl $(PROJ); synth_ice40 -blif $@'
-
-
-%.asc: $(PIN_DEF) %.blif
- arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^
-
-%.bin: %.asc
- icepack $< $@
-
-%.rpt: %.asc
- icetime -d $(DEVICE) -mtr $@ $<
-
-prog: $(PROJ).bin
- iceprog $<
-
-sudo-prog: $(PROJ).bin
- @echo 'Executing prog as root!!!'
- sudo iceprog $<
-
-clean:
- rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin work-obj93.cf
-
-.SECONDARY:
-.PHONY: all prog clean
diff --git a/icezum/counter-8bits/README.md b/icezum/counter-8bits/README.md
deleted file mode 100644
index 4549251..0000000
--- a/icezum/counter-8bits/README.md
+++ /dev/null
@@ -1,16 +0,0 @@
-An example for the **Icezum Alhambra board**
-A binary counter shown in the 8 test leds
-
-Execute
-
-```sh
-$ make
-```
-
-for synthesizing the example and
-
-```sh
-$ make prog
-```
-
-for programing the board
diff --git a/icezum/counter-8bits/counter8.pcf b/icezum/counter-8bits/counter8.pcf
deleted file mode 100644
index 9d25064..0000000
--- a/icezum/counter-8bits/counter8.pcf
+++ /dev/null
@@ -1,9 +0,0 @@
-set_io --warn-no-port led0 95 # output
-set_io --warn-no-port led1 96 # output
-set_io --warn-no-port led2 97 # output
-set_io --warn-no-port led3 98 # output
-set_io --warn-no-port led4 99 # output
-set_io --warn-no-port led5 101 # output
-set_io --warn-no-port led6 102 # output
-set_io --warn-no-port led7 104 # output
-set_io --warn-no-port clk 21
diff --git a/icezum/counter-8bits/counter8.vhdl b/icezum/counter-8bits/counter8.vhdl
deleted file mode 100644
index 4c5017e..0000000
--- a/icezum/counter-8bits/counter8.vhdl
+++ /dev/null
@@ -1,38 +0,0 @@
-library ieee;
-use ieee.std_logic_1164.all;
-use ieee.numeric_std.all;
-
-entity counter8 is
- port (clk : in std_logic;
- led0, led1, led2, led3, led4, led5, led6, led7 : out std_logic);
-end counter8;
-
-architecture synth of counter8 is
-
- signal clk_6hz : std_logic;
-
-begin
-
- -- Presscaler
- prescaler: process(clk)
- variable timer : unsigned (20 downto 0):=(others=>'0');
- begin
- if rising_edge(clk) then
- timer := timer + 1;
- clk_6hz <= timer(20);
- end if;
- end process;
-
- -- 8 bits counter
- process (clk_6hz)
- variable temp : unsigned (7 downto 0);
- begin
- if rising_edge(clk_6hz) then
- temp:= temp + 1;
-
- -- Show the counter on the icezum Alhambra leds
- (led7, led6, led5, led4, led3, led2, led1, led0) <= temp;
- end if;
- end process;
-
-end synth;
diff --git a/icezum/led_on/Makefile b/icezum/led_on/Makefile
deleted file mode 100644
index b85feb3..0000000
--- a/icezum/led_on/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-PROJ = led_on
-PIN_DEF = led_on.pcf
-DEVICE = hx1k
-
-all: $(PROJ).rpt $(PROJ).bin
-
-%.blif: %.vhdl
- ghdl -a $(PROJ).vhdl
- yosys -m ../../ghdl.so -p 'ghdl $(PROJ); synth_ice40 -blif $@'
-
-%.asc: $(PIN_DEF) %.blif
- arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^
-
-%.bin: %.asc
- icepack $< $@
-
-%.rpt: %.asc
- icetime -d $(DEVICE) -mtr $@ $<
-
-prog: $(PROJ).bin
- iceprog $<
-
-sudo-prog: $(PROJ).bin
- @echo 'Executing prog as root!!!'
- sudo iceprog $<
-
-clean:
- rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin work-obj93.cf
-
-.SECONDARY:
-.PHONY: all prog clean
diff --git a/icezum/led_on/README.md b/icezum/led_on/README.md
deleted file mode 100644
index 9073c11..0000000
--- a/icezum/led_on/README.md
+++ /dev/null
@@ -1,16 +0,0 @@
-A hello world example for the **Icezum Alhambra board**
-It just turn on the led0 and turn off the others
-
-Execute
-
-```sh
-$ make
-```
-
-for synthesizing the example and
-
-```sh
-$ make prog
-```
-
-for programing the board
diff --git a/icezum/led_on/led_on.pcf b/icezum/led_on/led_on.pcf
deleted file mode 100644
index 522e201..0000000
--- a/icezum/led_on/led_on.pcf
+++ /dev/null
@@ -1,9 +0,0 @@
-set_io led0 95
-set_io led1 96
-set_io led2 97
-set_io led3 98
-set_io led4 99
-set_io led5 101
-set_io led6 102
-set_io led7 104
-
diff --git a/icezum/led_on/led_on.vhdl b/icezum/led_on/led_on.vhdl
deleted file mode 100644
index 49a88ad..0000000
--- a/icezum/led_on/led_on.vhdl
+++ /dev/null
@@ -1,20 +0,0 @@
-library ieee;
-use ieee.std_logic_1164.all;
-use ieee.numeric_std.all;
-
-entity led_on is
- port (led0, led1, led2, led3, led4, led5, led6, led7 : out std_logic);
-end led_on;
-
-architecture test of led_on is
-begin
-
- -- Turn on the Led0
- led0 <= '1';
-
- -- Turn off the other leds
- (led1, led2, led3, led4, led5, led6, led7) <= std_logic_vector'("0000000");
-
-end test;
-
-
diff --git a/icezum/pushbutton/Makefile b/icezum/pushbutton/Makefile
deleted file mode 100644
index d483e9a..0000000
--- a/icezum/pushbutton/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-PROJ = pushbutton
-PIN_DEF = $(PROJ).pcf
-DEVICE = hx1k
-
-all: $(PROJ).rpt $(PROJ).bin
-
-%.blif: %.vhdl
- ghdl -a $(PROJ).vhdl
- yosys -m ../../ghdl.so -p 'ghdl $(PROJ); synth_ice40 -blif $@'
-
-
-%.asc: $(PIN_DEF) %.blif
- arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^
-
-%.bin: %.asc
- icepack $< $@
-
-%.rpt: %.asc
- icetime -d $(DEVICE) -mtr $@ $<
-
-prog: $(PROJ).bin
- iceprog $<
-
-sudo-prog: $(PROJ).bin
- @echo 'Executing prog as root!!!'
- sudo iceprog $<
-
-clean:
- rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin work-obj93.cf
-
-.SECONDARY:
-.PHONY: all prog clean
diff --git a/icezum/pushbutton/README.md b/icezum/pushbutton/README.md
deleted file mode 100644
index 6aba730..0000000
--- a/icezum/pushbutton/README.md
+++ /dev/null
@@ -1,17 +0,0 @@
-A hello world example for the **Icezum Alhambra board**
-Testing the sw1 pushbutton. The state of the button and its negated are wired
-to led0 and led7 respectively
-
-Execute
-
-```sh
-$ make
-```
-
-for synthesizing the example and
-
-```sh
-$ make prog
-```
-
-for programing the board
diff --git a/icezum/pushbutton/pushbutton.pcf b/icezum/pushbutton/pushbutton.pcf
deleted file mode 100644
index 807307f..0000000
--- a/icezum/pushbutton/pushbutton.pcf
+++ /dev/null
@@ -1,7 +0,0 @@
-set_io sw1 10
-set_io led0 95
-set_io led7 104
-
-
-
-
diff --git a/icezum/pushbutton/pushbutton.vhdl b/icezum/pushbutton/pushbutton.vhdl
deleted file mode 100644
index 8ad516e..0000000
--- a/icezum/pushbutton/pushbutton.vhdl
+++ /dev/null
@@ -1,14 +0,0 @@
-library ieee;
-use ieee.std_logic_1164.all;
-use ieee.numeric_std.all;
-
-entity pushbutton is
- port (sw1 : in std_logic;
- led0, led7 : out std_logic);
-end pushbutton;
-
-architecture synth of pushbutton is
-begin
- led0 <= sw1;
- led7 <= not sw1;
-end synth;
diff --git a/icezum/pushbutton_and/Makefile b/icezum/pushbutton_and/Makefile
deleted file mode 100644
index 2042685..0000000
--- a/icezum/pushbutton_and/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-PROJ = pushbutton_and
-PIN_DEF = $(PROJ).pcf
-DEVICE = hx1k
-
-all: $(PROJ).rpt $(PROJ).bin
-
-%.blif: %.vhdl
- ghdl -a $(PROJ).vhdl
- yosys -m ../../ghdl.so -p 'ghdl $(PROJ); synth_ice40 -blif $@'
-
-
-%.asc: $(PIN_DEF) %.blif
- arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^
-
-%.bin: %.asc
- icepack $< $@
-
-%.rpt: %.asc
- icetime -d $(DEVICE) -mtr $@ $<
-
-prog: $(PROJ).bin
- iceprog $<
-
-sudo-prog: $(PROJ).bin
- @echo 'Executing prog as root!!!'
- sudo iceprog $<
-
-clean:
- rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin work-obj93.cf
-
-.SECONDARY:
-.PHONY: all prog clean
diff --git a/icezum/pushbutton_and/README.md b/icezum/pushbutton_and/README.md
deleted file mode 100644
index b4734c5..0000000
--- a/icezum/pushbutton_and/README.md
+++ /dev/null
@@ -1,17 +0,0 @@
-A hello world example for the **Icezum Alhambra board**
-Testing the sw1 and sw1 pushbutton with an AND gate. The state of the AND
-and its negated are wired to the led0 and led7 respectively
-
-Execute
-
-```sh
-$ make
-```
-
-for synthesizing the example and
-
-```sh
-$ make prog
-```
-
-for programing the board
diff --git a/icezum/pushbutton_and/pushbutton_and.pcf b/icezum/pushbutton_and/pushbutton_and.pcf
deleted file mode 100644
index 31883fc..0000000
--- a/icezum/pushbutton_and/pushbutton_and.pcf
+++ /dev/null
@@ -1,4 +0,0 @@
-set_io sw1 10
-set_io sw2 11
-set_io led0 95
-set_io led7 104
diff --git a/icezum/pushbutton_and/pushbutton_and.vhdl b/icezum/pushbutton_and/pushbutton_and.vhdl
deleted file mode 100644
index 0a9831d..0000000
--- a/icezum/pushbutton_and/pushbutton_and.vhdl
+++ /dev/null
@@ -1,18 +0,0 @@
-library ieee;
-use ieee.std_logic_1164.all;
-use ieee.numeric_std.all;
-
-entity pushbutton_and is
- port (sw1, sw2 : in std_logic;
- led0, led7 : out std_logic);
-end pushbutton_and;
-
-architecture synth of pushbutton_and is
-
-signal a : std_logic;
-
-begin
- a <= sw1 and sw2;
- led0 <= a;
- led7 <= not a;
-end synth;