aboutsummaryrefslogtreecommitdiffstats
path: root/icezum/pushbutton_and
diff options
context:
space:
mode:
Diffstat (limited to 'icezum/pushbutton_and')
-rw-r--r--icezum/pushbutton_and/Makefile32
-rw-r--r--icezum/pushbutton_and/README.md17
-rw-r--r--icezum/pushbutton_and/pushbutton_and.pcf4
-rw-r--r--icezum/pushbutton_and/pushbutton_and.vhdl18
4 files changed, 0 insertions, 71 deletions
diff --git a/icezum/pushbutton_and/Makefile b/icezum/pushbutton_and/Makefile
deleted file mode 100644
index 2042685..0000000
--- a/icezum/pushbutton_and/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-PROJ = pushbutton_and
-PIN_DEF = $(PROJ).pcf
-DEVICE = hx1k
-
-all: $(PROJ).rpt $(PROJ).bin
-
-%.blif: %.vhdl
- ghdl -a $(PROJ).vhdl
- yosys -m ../../ghdl.so -p 'ghdl $(PROJ); synth_ice40 -blif $@'
-
-
-%.asc: $(PIN_DEF) %.blif
- arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^
-
-%.bin: %.asc
- icepack $< $@
-
-%.rpt: %.asc
- icetime -d $(DEVICE) -mtr $@ $<
-
-prog: $(PROJ).bin
- iceprog $<
-
-sudo-prog: $(PROJ).bin
- @echo 'Executing prog as root!!!'
- sudo iceprog $<
-
-clean:
- rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin work-obj93.cf
-
-.SECONDARY:
-.PHONY: all prog clean
diff --git a/icezum/pushbutton_and/README.md b/icezum/pushbutton_and/README.md
deleted file mode 100644
index b4734c5..0000000
--- a/icezum/pushbutton_and/README.md
+++ /dev/null
@@ -1,17 +0,0 @@
-A hello world example for the **Icezum Alhambra board**
-Testing the sw1 and sw1 pushbutton with an AND gate. The state of the AND
-and its negated are wired to the led0 and led7 respectively
-
-Execute
-
-```sh
-$ make
-```
-
-for synthesizing the example and
-
-```sh
-$ make prog
-```
-
-for programing the board
diff --git a/icezum/pushbutton_and/pushbutton_and.pcf b/icezum/pushbutton_and/pushbutton_and.pcf
deleted file mode 100644
index 31883fc..0000000
--- a/icezum/pushbutton_and/pushbutton_and.pcf
+++ /dev/null
@@ -1,4 +0,0 @@
-set_io sw1 10
-set_io sw2 11
-set_io led0 95
-set_io led7 104
diff --git a/icezum/pushbutton_and/pushbutton_and.vhdl b/icezum/pushbutton_and/pushbutton_and.vhdl
deleted file mode 100644
index 0a9831d..0000000
--- a/icezum/pushbutton_and/pushbutton_and.vhdl
+++ /dev/null
@@ -1,18 +0,0 @@
-library ieee;
-use ieee.std_logic_1164.all;
-use ieee.numeric_std.all;
-
-entity pushbutton_and is
- port (sw1, sw2 : in std_logic;
- led0, led7 : out std_logic);
-end pushbutton_and;
-
-architecture synth of pushbutton_and is
-
-signal a : std_logic;
-
-begin
- a <= sw1 and sw2;
- led0 <= a;
- led7 <= not a;
-end synth;