aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-18 02:21:11 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-21 14:18:07 +0100
commit0a388b5bf7b5dbc60df94594c77d932bdd95cba6 (patch)
treeca8b22af59a20a90289901cbe41cbb491141b549 /target/linux/mvebu/image/Makefile
parentb99b60b2f164cb62212dd9812ddc8ce8df9f90a9 (diff)
downloadupstream-0a388b5bf7b5dbc60df94594c77d932bdd95cba6.tar.gz
upstream-0a388b5bf7b5dbc60df94594c77d932bdd95cba6.tar.bz2
upstream-0a388b5bf7b5dbc60df94594c77d932bdd95cba6.zip
mvebu: move subtarget image Makefile switch to parent Makefile
This moves the if conditions for choosing which image Makefiles are used to the parent image/Makefile. It seems more convenient to have "codeflow" in the parent while the subtarget-specific files only contain the definitions. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target/linux/mvebu/image/Makefile')
-rw-r--r--target/linux/mvebu/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index ce1344a547..6dd7bde7ae 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -116,8 +116,16 @@ define Device/NAND-512K
PAGESIZE := 4096
endef
+ifeq ($(SUBTARGET),cortexa9)
include cortex-a9.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa53)
include cortex-a53.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa72)
include cortex-a72.mk
+endif
$(eval $(call BuildImage))