aboutsummaryrefslogtreecommitdiffstats
path: root/examples/ecp5_versa/Makefile
diff options
context:
space:
mode:
authorTristan Gingold <tgingold@free.fr>2020-03-31 18:39:09 +0200
committerTristan Gingold <tgingold@free.fr>2020-03-31 18:39:09 +0200
commitef286d8f3e02f7ef5b227f28e66b05122d816129 (patch)
tree0c8a6079e0fbe0fa80c7a21e09b0ff58a5165378 /examples/ecp5_versa/Makefile
parent31e54157acbceca921733da0a9fc521398f06e1b (diff)
downloadghdl-yosys-plugin-ef286d8f3e02f7ef5b227f28e66b05122d816129.tar.gz
ghdl-yosys-plugin-ef286d8f3e02f7ef5b227f28e66b05122d816129.tar.bz2
ghdl-yosys-plugin-ef286d8f3e02f7ef5b227f28e66b05122d816129.zip
Adjust ecp5_versa tests. Wrappers for verilog modules are not needed anymore.
Diffstat (limited to 'examples/ecp5_versa/Makefile')
-rw-r--r--examples/ecp5_versa/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/examples/ecp5_versa/Makefile b/examples/ecp5_versa/Makefile
index 6031055..2b54e17 100644
--- a/examples/ecp5_versa/Makefile
+++ b/examples/ecp5_versa/Makefile
@@ -21,10 +21,9 @@ VHDL_SYN_FILES += soc_iomap_pkg.vhdl
VHDL_SYN_FILES += uart.vhdl uart_tx.vhdl uart_rx.vhdl fifobuf.vhdl
TOPLEVEL = versa_ecp5_top
-TOPLEVEL_PARAMETER = _$(CLK_FREQ)
+TOPLEVEL_PARAMETER =
VERILOG_FILES = $(LIB)/wrapper/primitives.v
-VERILOG_FILES += $(LIB)/wrapper/wrapper.v
VERILOG_FILES += $(LIB)/wrapper/bram.v
SVFFILE = versa_ecp5_top.svf
@@ -39,10 +38,9 @@ lib:
mkdir $@
lib/ecp5um-std93.cf: $(LIB)/ecp5u/components.vhdl | lib
- $(GHDL) -i --workdir=$(dir $@) --work=ecp5um \
- $<
+ $(GHDL) -i --workdir=$(dir $@) --work=ecp5um $<
-pll_mac.vhd: $(DEPENDENCIES)
+pll_mac.vhd: $(DEPENDENCIES)
prog: $(SVFFILE)
$(OPENOCD) -f $(OPENOCD_JTAG_CONFIG) -f $(OPENOCD_DEVICE_CONFIG) \