aboutsummaryrefslogtreecommitdiffstats
path: root/examples/icestick
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2016-01-17 11:40:22 +0100
committerClifford Wolf <clifford@clifford.at>2016-01-17 11:40:22 +0100
commit7902d3ac3d0a519a07cb7c927e0722335a770f32 (patch)
treea19d501a0b4e767a66320f2ba5d393c58033ddcb /examples/icestick
parent7b7f75e44f17f704e2e46b29f1b866c7cbf56d00 (diff)
downloadicestorm-7902d3ac3d0a519a07cb7c927e0722335a770f32.tar.gz
icestorm-7902d3ac3d0a519a07cb7c927e0722335a770f32.tar.bz2
icestorm-7902d3ac3d0a519a07cb7c927e0722335a770f32.zip
Added icetime to examples
Diffstat (limited to 'examples/icestick')
-rw-r--r--examples/icestick/.gitignore3
-rw-r--r--examples/icestick/Makefile10
2 files changed, 9 insertions, 4 deletions
diff --git a/examples/icestick/.gitignore b/examples/icestick/.gitignore
index 4b77d1b..c1fa30b 100644
--- a/examples/icestick/.gitignore
+++ b/examples/icestick/.gitignore
@@ -1,3 +1,4 @@
example.bin
example.blif
-example.txt
+example.asc
+example.rpt
diff --git a/examples/icestick/Makefile b/examples/icestick/Makefile
index 06a5633..26b79f8 100644
--- a/examples/icestick/Makefile
+++ b/examples/icestick/Makefile
@@ -2,7 +2,7 @@ PROJ = example
PIN_DEF = icestick.pcf
DEVICE = 1k
-all: $(PROJ).bin
+all: $(PROJ).rpt $(PROJ).bin
%.blif: %.v
yosys -p 'synth_ice40 -top top -blif $@' $<
@@ -13,14 +13,18 @@ all: $(PROJ).bin
%.bin: %.asc
icepack $< $@
+%.rpt: %.asc
+ icetime -mt $< | tee $@
+
prog: $(PROJ).bin
iceprog $<
sudo-prog: $(PROJ).bin
@echo 'Executing prog as root!!!'
- iceprog $<
+ sudo iceprog $<
clean:
- rm -f $(PROJ).blif $(PROJ).asc $(PROJ).bin
+ rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin
+.SECONDARY:
.PHONY: all prog clean